Global IT infrastructure status

CLOUDFLARE

🟢 Operational

Email Notifications Delayed

Resolved

Started
2026-09-16 08:33 UTC
5 days ago
Last update
2026-09-16 08:50 UTC
5 days ago
Duration
17m

Timeline

  1. 16 Sep · 08:50 UTC 🟡 Resolved atom

    Sep 16, 08:50 UTC
    Resolved - This incident has been resolved.

    Sep 16, 08:33 UTC
    Investigating - Cloudflare is investigating delays with dispatching of notification emails for some customers. Webhooks and PagerDuty notifications are not affected.

  2. 16 Sep · 08:33 UTC ⚪ Investigating atom

    Sep 16, 08:33 UTC
    Investigating - Cloudflare is investigating delays with dispatching of notification emails for some customers. Webhooks and PagerDuty notifications are not affected.

Source

Official Cloudflare status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.