Global IT infrastructure status

STRIPE

🟢 Operational

Scheduled maintenance for TWINT

Resolved

Started
2026-09-21 23:00 UTC
11 min ago
Last update
2026-09-21 23:01 UTC
10 min ago
Duration
1m

Timeline

  1. 21 Sep · 23:01 UTC 🔵 Resolved atom

    Sep 21, 23:01 UTC
    Completed - The scheduled maintenance has been completed.

    Sep 21, 20:05 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 18, 10:20 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  2. 21 Sep · 23:00 UTC 🔵 Resolved atom

    Sep 21, 23:00 UTC
    Completed - The scheduled maintenance has been completed.

    Sep 21, 20:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 16, 23:00 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  3. 21 Sep · 23:00 UTC 🔵 Investigating atom

    Sep 21, 23:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 16, 12:00 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  4. 21 Sep · 20:05 UTC 🔵 Investigating atom

    Sep 21, 20:05 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 18, 10:20 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  5. 21 Sep · 20:00 UTC 🔵 Investigating atom

    Sep 21, 20:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 16, 23:00 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  6. 21 Sep · 05:30 UTC 🔵 Resolved atom

    Sep 21, 05:30 UTC
    Completed - The scheduled maintenance has been completed.

    Sep 21, 04:30 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 18, 17:50 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  7. 21 Sep · 04:30 UTC 🔵 Investigating atom

    Sep 21, 04:30 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 18, 17:50 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  8. 18 Sep · 17:50 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 21, 04:30 - 05:30 UTC

    Sep 18, 17:50 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  9. 18 Sep · 10:20 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 21, 20:05 - 23:00 UTC

    Sep 18, 10:20 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  10. 16 Sep · 23:00 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 21, 20:00 - 23:00 UTC

    Sep 16, 23:00 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  11. 16 Sep · 12:00 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 21, 23:00 UTC  -  Sep 22, 01:00 UTC

    Sep 16, 12:00 UTC
    Scheduled - TWINT has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

Source

Official Stripe status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.