🟢 Operational
Credit Card Support Calls Unavailable
Resolved
- Started
- 2026-09-16 16:35 UTC
5 days ago - Last update
- 2026-09-16 17:44 UTC
5 days ago - Duration
- 1h 9m
Timeline
-
16 Sep · 17:44 UTC
🟠 Resolved
atom
Sep 16, 13:44 EDT
Resolved - This incident has been resolved.
Sep 16, 12:35 EDT
Investigating - Customers are currently unable to reach Credit Card customer support by phone. All customer accounts and funds remain completely secure. -
16 Sep · 16:35 UTC
🟠 Investigating
atom
Sep 16, 12:35 EDT
Investigating - Customers are currently unable to reach Credit Card customer support by phone. All customer accounts and funds remain completely secure.
Source
Official Gemini Exchange status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.