Global IT infrastructure status

CLOUDFLARE

🟢 Operational

Increased HTTP 522 Errors in St. Louis

Resolved

Started
2026-09-16 18:35 UTC
5 days ago
Last update
2026-09-16 18:35 UTC
5 days ago
Duration
0s

Timeline

  1. 16 Sep · 18:35 UTC 🟢 Resolved atom

    Sep 16, 18:35 UTC
    Resolved - Customers may have observed elevated rates of HTTP 522 error responses from our St. Louis (STL) facility between approximately 16:35 and 16:55 UTC today, 2026-09-16.

Source

Official Cloudflare status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.