🟢 Operational
Invoice Generation Paused
Resolved
- Started
- 2026-09-16 03:21 UTC
5 days ago - Last update
- 2026-09-18 14:27 UTC
3 days ago - Duration
- 19h 54m
Timeline
-
18 Sep · 14:27 UTC
🟡 Resolved
atom
Sep 16, 03:21 UTC
Resolved - Invoice generation has been re-enabled.
---
We've identified the issue and expect to resolve by end-of-day today.
---
We've temporarily paused invoice generation. Invoices may arrive later than usual. Product availability and usage are unaffected, and no further action is required.
We're working on an update to re-enable invoice generation and we'll provide another update when invoicing resumes. -
17 Sep · 17:04 UTC
🟡 Resolved
atom
Sep 16, 03:21 UTC
Resolved - We've identified the issue and expect to resolve by end-of-day today.
---
We've temporarily paused invoice generation. Invoices may arrive later than usual. Product availability and usage are unaffected, and no further action is required.
We're working on an update to re-enable invoice generation and we'll provide another update when invoicing resumes. -
16 Sep · 23:15 UTC
🟢 Resolved
atom
Sep 16, 03:21 UTC
Resolved - We've temporarily paused invoice generation. Invoices may arrive later than usual. Product availability and usage are unaffected, and no further action is required.
We're working on an update to re-enable invoice generation and we'll provide another update when invoicing resumes.
Source
Official Vercel status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.