Global IT infrastructure status

COINBASE

🟡 Degraded

Delayed Sends and Receives - EGLD (MultiversX)

Investigating

Started
2026-09-19 08:49 UTC
2 days ago
Last update
2026-09-19 08:49 UTC
2 days ago
Running for
2d 15h

Timeline

  1. 19 Sep · 08:49 UTC 🟡 Investigating atom

    Sep 19, 01:49 PDT
    Investigating - We are aware that some users may experience delays in sends and receives on the MultiversX (EGLD) network due to a network issue. Buys, sells, and fiat withdrawals/deposits are not affected. Your funds are safe.

Source

Official Coinbase status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.