Global IT infrastructure status

GITHUB

🟢 Operational

Incident with Pull Requests

Resolved

Started
2026-09-20 22:13 UTC
1 day ago
Last update
2026-09-20 23:22 UTC
1 day ago
Duration
1h 8m

Timeline

  1. 20 Sep · 23:22 UTC 🟡 Resolved atom

    Sep 20, 23:22 UTC
    Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

    Sep 20, 22:32 UTC
    Update - A git fileserver issue caused a brief delay in creating some merge commits - we've isolated the underlying server and already observed recovery.

    Sep 20, 22:27 UTC
    Monitoring - The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.

    Sep 20, 22:13 UTC
    Investigating - We are investigating reports of degraded performance for Pull Requests

  2. 20 Sep · 22:32 UTC 🟡 Identified atom

    Sep 20, 22:32 UTC
    Update - A git fileserver issue caused a brief delay in creating some merge commits - we've isolated the underlying server and already observed recovery.

    Sep 20, 22:27 UTC
    Monitoring - The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.

    Sep 20, 22:13 UTC
    Investigating - We are investigating reports of degraded performance for Pull Requests

  3. 20 Sep · 22:13 UTC 🟡 Investigating atom

    Sep 20, 22:13 UTC
    Investigating - We are investigating reports of degraded performance for Pull Requests

Source

Official GitHub status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.