Global IT infrastructure status

GEMINI EXCHANGE

🟢 Operational

Scheduled maintenance - Trading Services Upgrade

Resolved

Started
2026-09-21 04:45 UTC
19 hours ago
Last update
2026-09-21 04:40 UTC
19 hours ago
Running for
19h 22m

Timeline

  1. 21 Sep · 04:40 UTC 🔵 Resolved atom

    Sep 21, 00:40 EDT
    Completed - The scheduled maintenance has been completed.

    Sep 21, 00:40 EDT
    Update - We will be undergoing scheduled maintenance during this time.

    Sep 21, 00:35 EDT
    Scheduled - Users may experience errors, failed trades, or failed API queries for a few minutes. All customer funds remain safe and secure.

  2. 21 Sep · 04:35 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 21, 00:45 - 01:45 EDT

    Sep 21, 00:35 EDT
    Scheduled - Users may experience errors, failed trades, or failed API queries for a few minutes. All customer funds remain safe and secure.

Source

Official Gemini Exchange status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.