🟡 Degraded
Performance degradation in APAC/Singapore
Investigating
- Started
- 2026-09-21 12:10 UTC
11 hours ago - Last update
- 2026-09-21 20:18 UTC
2 hours ago - Running for
- 11h 1m
Timeline
-
21 Sep · 20:18 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 15:17 UTC
Monitoring - Cloudflare confirmed the traffic degradation was resolved, with recovery observed at approximately 13:40 UTC. Our application and backend checks remained healthy during the degradation, supporting that the impact was outside the GitLab application stack. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 17:14 UTC
Monitoring - No material updates at this time. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 18:16 UTC
Monitoring - At this time the situation is unchanged. We will continue to monitor. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 19:16 UTC
Monitoring - We're still monitoring this incident. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 20:18 UTC
Resolved - At this time we are resolving this incident. If you continue to experience performance degradation in the Singapore area, please open a support ticket. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 19:16 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 15:17 UTC
Monitoring - Cloudflare confirmed the traffic degradation was resolved, with recovery observed at approximately 13:40 UTC. Our application and backend checks remained healthy during the degradation, supporting that the impact was outside the GitLab application stack. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 17:14 UTC
Monitoring - No material updates at this time. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 18:16 UTC
Monitoring - At this time the situation is unchanged. We will continue to monitor. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 19:16 UTC
Monitoring - We're still monitoring this incident. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 18:16 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 15:17 UTC
Monitoring - Cloudflare confirmed the traffic degradation was resolved, with recovery observed at approximately 13:40 UTC. Our application and backend checks remained healthy during the degradation, supporting that the impact was outside the GitLab application stack. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 17:14 UTC
Monitoring - No material updates at this time. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 18:16 UTC
Monitoring - At this time the situation is unchanged. We will continue to monitor. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 17:14 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 15:17 UTC
Monitoring - Cloudflare confirmed the traffic degradation was resolved, with recovery observed at approximately 13:40 UTC. Our application and backend checks remained healthy during the degradation, supporting that the impact was outside the GitLab application stack. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 17:14 UTC
Monitoring - No material updates at this time. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 15:17 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 15:17 UTC
Monitoring - Cloudflare confirmed the traffic degradation was resolved, with recovery observed at approximately 13:40 UTC. Our application and backend checks remained healthy during the degradation, supporting that the impact was outside the GitLab application stack. We will continue to monitor the situation. More details in gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 12:51 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
September 21, 2026 12:51 UTC
Investigating - We are still investigating the cause for the performance degradation. There are no material updates at the moment. The problem is tracked under https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981. -
21 Sep · 12:10 UTC
🟡 Investigating
rss
September 21, 2026 12:10 UTC
Investigating - We're experiencing degraded package, artifact, and registry download speed in APAC/Singapore region due to elevated CDN/Cloudflare latency. More details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22981.
Source
Official GitLab status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.