Global IT infrastructure status

GITLAB

🟡 Degraded

500 errors when fetching commits on GitLab.com

Investigating

Started
2026-08-18 17:30 UTC
34 days ago
Last update
2026-08-18 17:30 UTC
34 days ago
Running for
34d 6h

Timeline

  1. 18 Aug · 17:30 UTC 🟡 Investigating rss

    August 18, 2026 13:55 UTC
    Investigating - We are investigating an issue causing a subset of requests to GitLab.com receiving 500 errors. We will provide updates as we learn more from our investigation.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:16 UTC
    Investigating - We are still investigating the root cause for 500 errors while fetching commits on GitLab.com.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:31 UTC
    Investigating - Investigation for the root cause of 500 errors while fetching commits on GitLab.com is still ongoing.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:49 UTC
    Monitoring - Our monitoring shows the error rate decreasing towards normal thresholds. We're continuing to monitor the incident.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 16:11 UTC
    Monitoring - The error rate has continued to remain within normal thresholds. We're continuing to monitor the error rate.

    Further developments can be read here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 17:30 UTC
    Resolved - The error rate remains within normal thresholds and the issue is now resolved. Further details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

  2. 18 Aug · 17:30 UTC 🟡 Investigating rss

    August 18, 2026 13:55 UTC
    Investigating - We are investigating an issue causing a subset of requests to GitLab.com receiving 500 errors. We will provide updates as we learn more from our investigation.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:16 UTC
    Investigating - We are still investigating the root cause for 500 errors while fetching commits on GitLab.com.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:31 UTC
    Investigating - Investigation for the root cause of 500 errors while fetching commits on GitLab.com is still ongoing.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:49 UTC
    Monitoring - Our monitoring shows the error rate decreasing towards normal thresholds. We're continuing to monitor the incident.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 16:11 UTC
    Monitoring - The error rate has continued to remain within normal thresholds. We're continuing to monitor the error rate.

    Further developments can be read here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 17:30 UTC
    Resolved - The error rate remains within normal thresholds and the issue is now resolved. Further details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

  3. 18 Aug · 17:30 UTC 🟡 Investigating rss

    August 18, 2026 13:55 UTC
    Investigating - We are investigating an issue causing a subset of requests to GitLab.com receiving 500 errors. We will provide updates as we learn more from our investigation.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:16 UTC
    Investigating - We are still investigating the root cause for 500 errors while fetching commits on GitLab.com.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:31 UTC
    Investigating - Investigation for the root cause of 500 errors while fetching commits on GitLab.com is still ongoing.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 14:49 UTC
    Monitoring - Our monitoring shows the error rate decreasing towards normal thresholds. We're continuing to monitor the incident.

    More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 16:11 UTC
    Monitoring - The error rate has continued to remain within normal thresholds. We're continuing to monitor the error rate.

    Further developments can be read here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

    August 18, 2026 17:30 UTC
    Resolved - The error rate remains within normal thresholds and the issue is now resolved. Further details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22729

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.