Global IT infrastructure status

GITLAB

🟡 Degraded

Elevated queue times on saas-linux-medium-arm64 runner

Investigating

Started
2026-08-13 17:47 UTC
39 days ago
Last update
2026-08-13 17:47 UTC
39 days ago
Running for
39d 6h

Timeline

  1. 13 Aug · 17:47 UTC 🟡 Investigating rss

    August 13, 2026 13:58 UTC
    Investigating - We are seeing a growing queue of pending jobs on the saas-linux-medium-arm64 hosted runner on GitLab.com. We are rolling out a mitigation. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 15:22 UTC
    Monitoring - The issue is mitigated and the queue of pending jobs on saas-linux-medium-arm64 is going down. We are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 16:48 UTC
    Monitoring - The queue of pending jobs on the affected runners has returned to normal and we are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 17:47 UTC
    Resolved - The queue of pending jobs on the affected runners has returned to normal and has stayed at that level. This incident is now resolved. Please open a ticket with support if you are still seeing job delays. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

  2. 13 Aug · 17:47 UTC 🟡 Investigating rss

    August 13, 2026 13:58 UTC
    Investigating - We are seeing a growing queue of pending jobs on the saas-linux-medium-arm64 hosted runner on GitLab.com. We are rolling out a mitigation. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 15:22 UTC
    Monitoring - The issue is mitigated and the queue of pending jobs on saas-linux-medium-arm64 is going down. We are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 16:48 UTC
    Monitoring - The queue of pending jobs on the affected runners has returned to normal and we are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 17:47 UTC
    Resolved - The queue of pending jobs on the affected runners has returned to normal and has stayed at that level. This incident is now resolved. Please open a ticket with support if you are still seeing job delays. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

  3. 13 Aug · 17:47 UTC 🟡 Investigating rss

    August 13, 2026 13:58 UTC
    Investigating - We are seeing a growing queue of pending jobs on the saas-linux-medium-arm64 hosted runner on GitLab.com. We are rolling out a mitigation. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 15:22 UTC
    Monitoring - The issue is mitigated and the queue of pending jobs on saas-linux-medium-arm64 is going down. We are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 16:48 UTC
    Monitoring - The queue of pending jobs on the affected runners has returned to normal and we are monitoring recovery. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

    August 13, 2026 17:47 UTC
    Resolved - The queue of pending jobs on the affected runners has returned to normal and has stayed at that level. This incident is now resolved. Please open a ticket with support if you are still seeing job delays. Details: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22702

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.