Global IT infrastructure status

GITLAB

🟡 Degraded

Issues with pipelines

Investigating

Started
2026-08-05 23:47 UTC
47 days ago
Last update
2026-08-05 23:47 UTC
47 days ago
Running for
47d

Timeline

  1. 05 Aug · 23:47 UTC 🟡 Investigating rss

    August 5, 2026 22:13 UTC
    Investigating - We're investigating reports of pipelines failing and becoming stuck. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 22:39 UTC
    Investigating - We've disabled a worker, which should let the job queue begin recovering while we continue investigating the root cause. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:26 UTC
    Identified - We've identified a likely root cause, and the job queue has remained healthy. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:47 UTC
    Resolved - We've applied mitigations that have stabilized the job queue. The issue is now resolved. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

  2. 05 Aug · 23:47 UTC 🟡 Investigating rss

    August 5, 2026 22:13 UTC
    Investigating - We're investigating reports of pipelines failing and becoming stuck. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 22:39 UTC
    Investigating - We've disabled a worker, which should let the job queue begin recovering while we continue investigating the root cause. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:26 UTC
    Identified - We've identified a likely root cause, and the job queue has remained healthy. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:47 UTC
    Resolved - We've applied mitigations that have stabilized the job queue. The issue is now resolved. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

  3. 05 Aug · 23:47 UTC 🟡 Investigating rss

    August 5, 2026 22:13 UTC
    Investigating - We're investigating reports of pipelines failing and becoming stuck. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 22:39 UTC
    Investigating - We've disabled a worker, which should let the job queue begin recovering while we continue investigating the root cause. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:26 UTC
    Identified - We've identified a likely root cause, and the job queue has remained healthy. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

    August 5, 2026 23:47 UTC
    Resolved - We've applied mitigations that have stabilized the job queue. The issue is now resolved. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22654.

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.