Global IT infrastructure status

GITLAB

🟡 Degraded

Issues with webhook deliveries

Investigating

Started
2026-08-05 15:19 UTC
47 days ago
Last update
2026-08-05 15:19 UTC
47 days ago
Running for
47d 8h

Timeline

  1. 05 Aug · 15:19 UTC 🟡 Investigating rss

    August 4, 2026 16:42 UTC
    Investigating - We are investigating reports of webhook deliveries from GitLab.com originating from IP addresses outside our documented ranges. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 4, 2026 18:49 UTC
    Investigating - Our investigation is ongoing. We will provide another update by 21:00 UTC.

    August 4, 2026 21:07 UTC
    Identified - We've traced the issue to a recent network change and are preparing a fix. Another update will be provided by 23:00 UTC.

    August 4, 2026 23:14 UTC
    Identified - Deployment of the fix is progressing steadily. Another update will be provided once deployed. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 5, 2026 03:26 UTC
    Monitoring - A fix has been deployed and checks have confirmed that unexpected IP addresses are no longer being used.

    August 5, 2026 15:19 UTC
    Resolved - Webhook delivery failures have subsided in logs, and customer reports indicate no further errors. This incident is considered resolved.

  2. 05 Aug · 15:19 UTC 🟡 Investigating rss

    August 4, 2026 16:42 UTC
    Investigating - We are investigating reports of webhook deliveries from GitLab.com originating from IP addresses outside our documented ranges. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 4, 2026 18:49 UTC
    Investigating - Our investigation is ongoing. We will provide another update by 21:00 UTC.

    August 4, 2026 21:07 UTC
    Identified - We've traced the issue to a recent network change and are preparing a fix. Another update will be provided by 23:00 UTC.

    August 4, 2026 23:14 UTC
    Identified - Deployment of the fix is progressing steadily. Another update will be provided once deployed. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 5, 2026 03:26 UTC
    Monitoring - A fix has been deployed and checks have confirmed that unexpected IP addresses are no longer being used.

    August 5, 2026 15:19 UTC
    Resolved - Webhook delivery failures have subsided in logs, and customer reports indicate no further errors. This incident is considered resolved.

  3. 05 Aug · 15:19 UTC 🟡 Investigating rss

    August 4, 2026 16:42 UTC
    Investigating - We are investigating reports of webhook deliveries from GitLab.com originating from IP addresses outside our documented ranges. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 4, 2026 18:49 UTC
    Investigating - Our investigation is ongoing. We will provide another update by 21:00 UTC.

    August 4, 2026 21:07 UTC
    Identified - We've traced the issue to a recent network change and are preparing a fix. Another update will be provided by 23:00 UTC.

    August 4, 2026 23:14 UTC
    Identified - Deployment of the fix is progressing steadily. Another update will be provided once deployed. Details in https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22637.

    August 5, 2026 03:26 UTC
    Monitoring - A fix has been deployed and checks have confirmed that unexpected IP addresses are no longer being used.

    August 5, 2026 15:19 UTC
    Resolved - Webhook delivery failures have subsided in logs, and customer reports indicate no further errors. This incident is considered resolved.

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.