Global IT infrastructure status

GITLAB

🟡 Degraded

Elevated error rates on GitLab.com

Investigating

Started
2026-07-27 21:11 UTC
56 days ago
Last update
2026-07-27 21:11 UTC
56 days ago
Running for
56d 2h

Timeline

  1. 27 Jul · 21:11 UTC 🟡 Investigating rss

    July 27, 2026 20:09 UTC
    Investigating - We observed a spike in 5xx errors on GitLab.com. These have subsided, but we are investigating the root cause.

    July 27, 2026 20:28 UTC
    Monitoring - We have confirmed these errors are no longer occurring. We've identified the cause of this incident and are working to prevent this from occurring in the future. We'll now move this incident to monitoring. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

    July 27, 2026 21:11 UTC
    Resolved - We have continued to observe normal error rates. We will now be marking this incident as resolved. Details surrounding the incident can be seen here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

  2. 27 Jul · 21:11 UTC 🟡 Investigating rss

    July 27, 2026 20:09 UTC
    Investigating - We observed a spike in 5xx errors on GitLab.com. These have subsided, but we are investigating the root cause.

    July 27, 2026 20:28 UTC
    Monitoring - We have confirmed these errors are no longer occurring. We've identified the cause of this incident and are working to prevent this from occurring in the future. We'll now move this incident to monitoring. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

    July 27, 2026 21:11 UTC
    Resolved - We have continued to observe normal error rates. We will now be marking this incident as resolved. Details surrounding the incident can be seen here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

  3. 27 Jul · 21:11 UTC 🟡 Investigating rss

    July 27, 2026 20:09 UTC
    Investigating - We observed a spike in 5xx errors on GitLab.com. These have subsided, but we are investigating the root cause.

    July 27, 2026 20:28 UTC
    Monitoring - We have confirmed these errors are no longer occurring. We've identified the cause of this incident and are working to prevent this from occurring in the future. We'll now move this incident to monitoring. Details: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

    July 27, 2026 21:11 UTC
    Resolved - We have continued to observe normal error rates. We will now be marking this incident as resolved. Details surrounding the incident can be seen here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22579

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.