Global IT infrastructure status

VERCEL

🟢 Operational

Timeouts loading charts and observability data in Dashboard

Resolved

Started
2026-07-23 08:18 UTC
60 days ago
Last update
2026-07-23 08:18 UTC
60 days ago
Duration
1s

Timeline

  1. 23 Jul · 08:18 UTC 🟡 Resolved atom

    Jul 23, 08:18 UTC
    Resolved - This incident has been resolved.

    Jul 23, 07:55 UTC
    Monitoring - The team identified the source of the issue and a fix has been implemented. We are starting to see recovery. Charts and observability data should be loading again for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. We continue to monitor.

    Jul 23, 07:33 UTC
    Investigating - We are currently investigating timeouts loading observability data for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. This impacts charts in the Dashboard.

  2. 23 Jul · 08:18 UTC 🟡 Resolved atom

    Jul 23, 08:18 UTC
    Resolved - This incident has been resolved.

    Jul 23, 07:55 UTC
    Monitoring - The team identified the source of the issue and a fix has been implemented. We are starting to see recovery. Charts and observability data should be loading again for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. We continue to monitor.

    Jul 23, 07:33 UTC
    Investigating - We are currently investigating timeouts loading observability data for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. This impacts charts in the Dashboard.

  3. 23 Jul · 08:18 UTC 🟡 Resolved atom

    Jul 23, 08:18 UTC
    Resolved - This incident has been resolved.

    Jul 23, 07:55 UTC
    Monitoring - The team identified the source of the issue and a fix has been implemented. We are starting to see recovery. Charts and observability data should be loading again for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. We continue to monitor.

    Jul 23, 07:33 UTC
    Investigating - We are currently investigating timeouts loading observability data for Firewall, Observability, Sandboxes, Speed Insights, Web Analytics, and Workflows. This impacts charts in the Dashboard.

Source

Official Vercel status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.