Global IT infrastructure status

VERCEL

🟢 Operational

GitHub-linked deployments and authentication affected

Resolved

Started
2026-07-17 00:42 UTC
66 days ago
Last update
2026-07-17 00:42 UTC
66 days ago
Duration
0s

Timeline

  1. 17 Jul · 00:42 UTC 🟡 Resolved atom

    Jul 17, 00:42 UTC
    Resolved - This incident has been resolved.

    Jul 17, 00:07 UTC
    Monitoring - Deployments for projects linked to GitHub repositories are recovering. Some customers may continue to experience delayed build starts or builds stuck in an initializing state while recovery continues. We will provide additional updates as they become available. GitHub login, signup, and account connections are recovered.

    Jul 16, 23:39 UTC
    Identified - We've identified an issue affecting deployments for projects linked to GitHub repositories, as well as GitHub login, signup, and account connections. CLI deployments and other sign-in methods are unaffected. We will share updates as they become available.

    Jul 16, 23:09 UTC
    Investigating - We are investigating elevated error rates for users logging in to Vercel using their GitHub account and connecting their GitHub accounts to Vercel. Login with email or other sign-in methods is unaffected.

  2. 17 Jul · 00:42 UTC 🟡 Resolved atom

    Jul 17, 00:42 UTC
    Resolved - This incident has been resolved.

    Jul 17, 00:07 UTC
    Monitoring - Deployments for projects linked to GitHub repositories are recovering. Some customers may continue to experience delayed build starts or builds stuck in an initializing state while recovery continues. We will provide additional updates as they become available. GitHub login, signup, and account connections are recovered.

    Jul 16, 23:39 UTC
    Identified - We've identified an issue affecting deployments for projects linked to GitHub repositories, as well as GitHub login, signup, and account connections. CLI deployments and other sign-in methods are unaffected. We will share updates as they become available.

    Jul 16, 23:09 UTC
    Investigating - We are investigating elevated error rates for users logging in to Vercel using their GitHub account and connecting their GitHub accounts to Vercel. Login with email or other sign-in methods is unaffected.

  3. 17 Jul · 00:42 UTC 🟡 Resolved atom

    Jul 17, 00:42 UTC
    Resolved - This incident has been resolved.

    Jul 17, 00:07 UTC
    Monitoring - Deployments for projects linked to GitHub repositories are recovering. Some customers may continue to experience delayed build starts or builds stuck in an initializing state while recovery continues. We will provide additional updates as they become available. GitHub login, signup, and account connections are recovered.

    Jul 16, 23:39 UTC
    Identified - We've identified an issue affecting deployments for projects linked to GitHub repositories, as well as GitHub login, signup, and account connections. CLI deployments and other sign-in methods are unaffected. We will share updates as they become available.

    Jul 16, 23:09 UTC
    Investigating - We are investigating elevated error rates for users logging in to Vercel using their GitHub account and connecting their GitHub accounts to Vercel. Login with email or other sign-in methods is unaffected.

Source

Official Vercel status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.