Global IT infrastructure status

VERCEL

🟢 Operational

Increased Build failure rates

Resolved

Started
2026-07-10 23:28 UTC
73 days ago
Last update
2026-07-10 23:28 UTC
73 days ago
Duration
0s

Timeline

  1. 10 Jul · 23:28 UTC 🟡 Resolved atom

    Jul 10, 23:28 UTC
    Resolved - This incident has been resolved.

    Jul 10, 21:22 UTC
    Monitoring - We've identified an issue where some customers may experience failed Builds beginning at 21:05 UTC.

    A rollback is in progress to mitigate this issue. We will provide additional updates as they become available.

    Failed deployments can be retried and should succeed.

  2. 10 Jul · 23:28 UTC 🟡 Resolved atom

    Jul 10, 23:28 UTC
    Resolved - This incident has been resolved.

    Jul 10, 21:22 UTC
    Monitoring - We've identified an issue where some customers may experience failed Builds beginning at 21:05 UTC.

    A rollback is in progress to mitigate this issue. We will provide additional updates as they become available.

    Failed deployments can be retried and should succeed.

  3. 10 Jul · 23:28 UTC 🟡 Resolved atom

    Jul 10, 23:28 UTC
    Resolved - This incident has been resolved.

    Jul 10, 21:22 UTC
    Monitoring - We've identified an issue where some customers may experience failed Builds beginning at 21:05 UTC.

    A rollback is in progress to mitigate this issue. We will provide additional updates as they become available.

    Failed deployments can be retried and should succeed.

Source

Official Vercel status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.