🟢 Operational
Delays loading Build Logs
Resolved
- Started
- 2026-07-09 13:16 UTC
74 days ago - Last update
- 2026-07-10 17:44 UTC
73 days ago - Duration
- 1d 4h
Timeline
-
10 Jul · 17:44 UTC
🟡 Resolved
atom
Jul 9, 13:16 UTC
Resolved - The issue affecting Build Logs has been resolved. Between Jul 8 19:05 UTC and Jul 9 13:16 UTC, some Pro customers using standard machine types may have experienced missing Build Logs.
New builds after the impact period are unaffected. -
10 Jul · 17:44 UTC
🟡 Resolved
atom
Jul 9, 13:16 UTC
Resolved - The issue affecting Build Logs has been resolved. Between Jul 8 19:05 UTC and Jul 9 13:16 UTC, some Pro customers using standard machine types may have experienced missing Build Logs.
New builds after the impact period are unaffected. -
10 Jul · 17:44 UTC
🟡 Resolved
atom
Jul 9, 13:16 UTC
Resolved - The issue affecting Build Logs has been resolved. Between Jul 8 19:05 UTC and Jul 9 13:16 UTC, some Pro customers using standard machine types may have experienced missing Build Logs.
New builds after the impact period are unaffected.
Source
Official Vercel status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.