🟢 Operational
Resolved: Impact to Withdrawals (PP-LIVE-107852)
Resolved
- Started
- 2026-07-28 07:28 UTC
55 days ago - Last update
- 2026-07-28 07:28 UTC
55 days ago - Duration
- 0s
Timeline
-
28 Jul · 07:28 UTC
🟡 Resolved
atom
Resolved: The impact to Withdrawals in our Production Environment has been mitigated.
Our technical teams are actively working to ensure full recovery.
Initial Notification: We are currently experiencing Degraded Performance affecting Withdrawals. Our team is working on resolving the issue and mitigating the impact.
Affected Regions: EMEA -
28 Jul · 07:28 UTC
🟡 Resolved
atom
Resolved: The impact to Withdrawals in our Production Environment has been mitigated.
Our technical teams are actively working to ensure full recovery.
Initial Notification: We are currently experiencing Degraded Performance affecting Withdrawals. Our team is working on resolving the issue and mitigating the impact.
Affected Regions: EMEA -
28 Jul · 07:28 UTC
🟡 Resolved
atom
Resolved: The impact to Withdrawals in our Production Environment has been mitigated.
Our technical teams are actively working to ensure full recovery.
Initial Notification: We are currently experiencing Degraded Performance affecting Withdrawals. Our team is working on resolving the issue and mitigating the impact.
Affected Regions: EMEA
Source
Official PayPal status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.