Global IT infrastructure status

GEMINI EXCHANGE

🟢 Operational

SMS text may be briefly delayed or unavailable on Tuesday, August 25th @ 10:00am EST.

Resolved

Started
2026-08-25 14:00 UTC
27 days ago
Last update
2026-08-25 15:00 UTC
27 days ago
Duration
1h

Timeline

  1. 25 Aug · 15:00 UTC 🔵 Resolved atom

    Aug 25, 11:00 EDT
    Completed - The scheduled maintenance has been completed.

    Aug 25, 10:00 EDT
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

  2. 25 Aug · 14:00 UTC 🔵 Investigating atom

    Aug 25, 10:00 EDT
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

  3. 25 Aug · 13:00 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Aug 25, 10:00 - 11:00 EDT

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

  4. 19 Aug · 19:48 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Aug 25, 10:00 - 11:00 EDT

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

  5. 19 Aug · 19:48 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Aug 25, 10:00 - 11:00 EDT

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

  6. 19 Aug · 19:48 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Aug 25, 10:00 - 11:00 EDT

    Aug 19, 15:48 EDT
    Scheduled - We will be undergoing scheduled maintenance during this time.

Source

Official Gemini Exchange status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.