🟢 Operational
Scheduled maintenance - Trading services upgrade
Resolved
- Started
- 2026-08-20 08:00 UTC
32 days ago - Last update
- 2026-08-20 08:00 UTC
32 days ago - Duration
- 0s
Timeline
-
20 Aug · 08:00 UTC
🔵 Resolved
atom
Aug 20, 04:00 EDT
Completed - The scheduled maintenance has been completed.
Aug 19, 22:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 18, 23:40 EDT
Update - We will be undergoing scheduled maintenance during this time.
Aug 18, 23:40 EDT
Scheduled - During this time, FIX Order Entry primary node will be unavailable. -
20 Aug · 08:00 UTC
🔵 Resolved
atom
Aug 20, 04:00 EDT
Completed - The scheduled maintenance has been completed.
Aug 19, 22:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 18, 23:40 EDT
Update - We will be undergoing scheduled maintenance during this time.
Aug 18, 23:40 EDT
Scheduled - During this time, FIX Order Entry primary node will be unavailable. -
20 Aug · 08:00 UTC
🔵 Resolved
atom
Aug 20, 04:00 EDT
Completed - The scheduled maintenance has been completed.
Aug 19, 22:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 18, 23:40 EDT
Update - We will be undergoing scheduled maintenance during this time.
Aug 18, 23:40 EDT
Scheduled - During this time, FIX Order Entry primary node will be unavailable.
Source
Official Gemini Exchange status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.