🟢 Operational
Exchange service upgrade
Resolved
- Started
- 2026-08-16 03:45 UTC
36 days ago - Last update
- 2026-08-16 03:45 UTC
36 days ago - Duration
- 0s
Timeline
-
16 Aug · 03:45 UTC
🔵 Resolved
atom
Aug 15, 23:45 EDT
Completed - The scheduled maintenance has been completed.
Aug 15, 23:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 15, 23:08 EDT
Scheduled - During Exchange service upgrade, potentially the orders may get timeouts in a very brief period. -
16 Aug · 03:45 UTC
🔵 Resolved
atom
Aug 15, 23:45 EDT
Completed - The scheduled maintenance has been completed.
Aug 15, 23:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 15, 23:08 EDT
Scheduled - During Exchange service upgrade, potentially the orders may get timeouts in a very brief period. -
16 Aug · 03:45 UTC
🔵 Resolved
atom
Aug 15, 23:45 EDT
Completed - The scheduled maintenance has been completed.
Aug 15, 23:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 15, 23:08 EDT
Scheduled - During Exchange service upgrade, potentially the orders may get timeouts in a very brief period.
Source
Official Gemini Exchange status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.