Global IT infrastructure status

GITLAB

🟠 Partial outage

Investigating GitLab Agent for Kubernetes (KAS) Deployment Failures

Investigating

Started
2026-08-24 21:22 UTC
28 days ago
Last update
2026-08-24 22:45 UTC
28 days ago
Running for
28d 2h

Timeline

  1. 24 Aug · 22:45 UTC 🟠 Investigating rss

    August 24, 2026 21:22 UTC
    Investigating - We are currently investigating reports of deployment failures affecting GitLab Agent for Kubernetes (KAS). Our team is actively looking into the root cause and will provide updates as the investigation progresses. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 21:37 UTC
    Identified - We have identified a recent change believed to be contributing to the deployment failures affecting KAS. We are actively reverting this change and will provide an update once complete. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 22:28 UTC
    Monitoring - The rollback has been completed and we are actively monitoring to confirm resolution of the deployment failures affecting KAS. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 22:45 UTC
    Resolved - The deployment failures affecting the GitLab Agent for Kubernetes (KAS) have been resolved. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

  2. 24 Aug · 22:28 UTC 🟠 Investigating rss

    August 24, 2026 21:22 UTC
    Investigating - We are currently investigating reports of deployment failures affecting GitLab Agent for Kubernetes (KAS). Our team is actively looking into the root cause and will provide updates as the investigation progresses. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 21:37 UTC
    Identified - We have identified a recent change believed to be contributing to the deployment failures affecting KAS. We are actively reverting this change and will provide an update once complete. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 22:28 UTC
    Monitoring - The rollback has been completed and we are actively monitoring to confirm resolution of the deployment failures affecting KAS. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

  3. 24 Aug · 21:37 UTC 🟠 Investigating rss

    August 24, 2026 21:22 UTC
    Investigating - We are currently investigating reports of deployment failures affecting GitLab Agent for Kubernetes (KAS). Our team is actively looking into the root cause and will provide updates as the investigation progresses. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

    August 24, 2026 21:37 UTC
    Identified - We have identified a recent change believed to be contributing to the deployment failures affecting KAS. We are actively reverting this change and will provide an update once complete. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

  4. 24 Aug · 21:22 UTC 🟠 Investigating rss

    August 24, 2026 21:22 UTC
    Investigating - We are currently investigating reports of deployment failures affecting GitLab Agent for Kubernetes (KAS). Our team is actively looking into the root cause and will provide updates as the investigation progresses. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22777

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.