Global IT infrastructure status

GITLAB

🟡 Degraded

General slowness and intermittent 502s on Gitlab.com

Investigating

Started
2026-08-25 09:59 UTC
27 days ago
Last update
2026-08-26 00:12 UTC
26 days ago
Running for
27d 14h

Timeline

  1. 26 Aug · 00:12 UTC 🟡 Investigating rss

    August 25, 2026 09:59 UTC
    Investigating - We are currently investigating reports of slowness and 502 errors. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 13:43 UTC
    Investigating - Slowness & 502s have been bursty with not much impact. A revert MR is under way while we are investigating other possible root causes. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 14:48 UTC
    Monitoring - We have not seen active user impact for several hours and we have identified the possible root cause. We are monitoring for changes. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 18:34 UTC
    Monitoring - We continue to monitor and have not observed any active user impact. We are working towards a permanent fix and will provide our next update once it has been implemented. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 26, 2026 00:12 UTC
    Resolved - The fix has been implemented and the issue is now resolved. We have not observed any active user impact. More information: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

  2. 25 Aug · 18:34 UTC 🟡 Investigating rss

    August 25, 2026 09:59 UTC
    Investigating - We are currently investigating reports of slowness and 502 errors. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 13:43 UTC
    Investigating - Slowness & 502s have been bursty with not much impact. A revert MR is under way while we are investigating other possible root causes. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 14:48 UTC
    Monitoring - We have not seen active user impact for several hours and we have identified the possible root cause. We are monitoring for changes. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 18:34 UTC
    Monitoring - We continue to monitor and have not observed any active user impact. We are working towards a permanent fix and will provide our next update once it has been implemented. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

  3. 25 Aug · 14:48 UTC 🟡 Investigating rss

    August 25, 2026 09:59 UTC
    Investigating - We are currently investigating reports of slowness and 502 errors. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 13:43 UTC
    Investigating - Slowness & 502s have been bursty with not much impact. A revert MR is under way while we are investigating other possible root causes. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 14:48 UTC
    Monitoring - We have not seen active user impact for several hours and we have identified the possible root cause. We are monitoring for changes. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

  4. 25 Aug · 13:43 UTC 🟡 Investigating rss

    August 25, 2026 09:59 UTC
    Investigating - We are currently investigating reports of slowness and 502 errors. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

    August 25, 2026 13:43 UTC
    Investigating - Slowness & 502s have been bursty with not much impact. A revert MR is under way while we are investigating other possible root causes. More information here: gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

  5. 25 Aug · 09:59 UTC 🟡 Investigating rss

    August 25, 2026 09:59 UTC
    Investigating - We are currently investigating reports of slowness and 502 errors. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22783

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.