Global IT infrastructure status

GITLAB

🟠 Partial outage

HTTP 500 errors affecting GitLab.com

Investigating

Started
2026-08-27 11:46 UTC
25 days ago
Last update
2026-08-27 15:34 UTC
25 days ago
Running for
25d 12h

Timeline

  1. 27 Aug · 15:34 UTC 🟠 Investigating rss

    August 27, 2026 11:46 UTC
    Investigating - There are elevated HTTP 500 errors affecting users accessing their Pipelines. Our engineers are actively investigating the issue and working to restore normal service.

    August 27, 2026 11:53 UTC
    Monitoring - The issue has been identified and resolved. We are monitoring for changes. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22807

    August 27, 2026 15:34 UTC
    Resolved - Performance remains stable and prevention steps are being implemented. Find more information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22807

  2. 27 Aug · 11:53 UTC 🟠 Investigating rss

    August 27, 2026 11:46 UTC
    Investigating - There are elevated HTTP 500 errors affecting users accessing their Pipelines. Our engineers are actively investigating the issue and working to restore normal service.

    August 27, 2026 11:53 UTC
    Monitoring - The issue has been identified and resolved. We are monitoring for changes. More information here: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22807

  3. 27 Aug · 11:46 UTC 🟠 Investigating rss

    August 27, 2026 11:46 UTC
    Investigating - There are elevated HTTP 500 errors affecting users accessing their Pipelines. Our engineers are actively investigating the issue and working to restore normal service.

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.