🟡 Degraded
Investigating delayed CI job pickup
Identified
- Started
- 2026-09-02 11:54 UTC
19 days ago - Last update
- 2026-09-02 12:43 UTC
19 days ago - Running for
- 19d 12h
Timeline
-
02 Sep · 12:43 UTC
🟡 Identified
rss
September 2, 2026 11:54 UTC
Identified - We are investigating an incident affecting GitLab.com CI/CD jobs using instance runners. Some jobs may remain pending longer than expected or may not be picked up by a runner, which can delay pipelines and deployments.
More info: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22845
September 2, 2026 12:43 UTC
Resolved - The incident affecting GitLab.com CI/CD jobs using instance runners is now resolved. Some jobs were delayed or remained pending while a manually initiated pg_repack database maintenance operation caused contention on the CI database, affecting runner communication and job pickup.
The maintenance operation was terminated and runner metrics recovered. More info: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22845 -
02 Sep · 11:54 UTC
🟡 Identified
rss
September 2, 2026 11:54 UTC
Identified - We are investigating an incident affecting GitLab.com CI/CD jobs using instance runners. Some jobs may remain pending longer than expected or may not be picked up by a runner, which can delay pipelines and deployments. -
02 Sep · 11:54 UTC
🟡 Identified
rss
September 2, 2026 11:54 UTC
Identified - We are investigating an incident affecting GitLab.com CI/CD jobs using instance runners. Some jobs may remain pending longer than expected or may not be picked up by a runner, which can delay pipelines and deployments.
More info: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22845
Source
Official GitLab status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.