Global IT infrastructure status

STRIPE

🔵 Maintenance

Scheduled maintenance for P24

Investigating

Started
2026-09-20 23:00 UTC
1 day ago
Last update
2026-09-20 23:00 UTC
1 day ago
Running for
1d

Timeline

  1. 20 Sep · 23:00 UTC 🔵 Investigating atom

    Sep 20, 23:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 3, 15:30 UTC
    Scheduled - P24 has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

  2. 03 Sep · 15:30 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 20, 23:00 UTC  -  Sep 21, 01:00 UTC

    Sep 3, 15:30 UTC
    Scheduled - P24 has an upcoming scheduled maintenance.

    Note: Stripe retrieves payment method planned maintenance information from payment method partners and the information may not be complete, accurate, or up to date.

Source

Official Stripe status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.