Global IT infrastructure status

VERCEL

🟢 Operational

Elevated latency in VCR, Blob, and Sandbox API

Resolved

Started
2026-09-04 19:11 UTC
17 days ago
Last update
2026-09-04 20:29 UTC
17 days ago
Duration
1h 15m

Timeline

  1. 04 Sep · 20:29 UTC 🟡 Resolved atom

    Sep 4, 20:27 UTC
    Resolved - Blob has fully recovered. This incident has been resolved.

    Sep 4, 20:19 UTC
    Update - Elevated latency has recovered for VCR and Sandbox. We are continuing to investigate elevated latency affecting Blob and will provide another update shortly.

    Sep 4, 20:05 UTC
    Monitoring - The fix has been rolled out and we are seeing signs of recovery.

    Sep 4, 19:55 UTC
    Update - The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  2. 04 Sep · 20:27 UTC 🟡 Resolved atom

    Sep 4, 20:27 UTC
    Resolved - This incident has been resolved.

    Sep 4, 20:19 UTC
    Update - Elevated latency has recovered for VCR and Sandbox. We are continuing to investigate elevated latency affecting Blob and will provide another update shortly.

    Sep 4, 20:05 UTC
    Monitoring - The fix has been rolled out and we are seeing signs of recovery.

    Sep 4, 19:55 UTC
    Update - The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  3. 04 Sep · 20:19 UTC 🟡 Identified atom

    Sep 4, 20:19 UTC
    Update - Elevated latency has recovered for VCR and Sandbox. We are continuing to investigate elevated latency affecting Blob and will provide another update shortly.

    Sep 4, 20:05 UTC
    Monitoring - The fix has been rolled out and we are seeing signs of recovery.

    Sep 4, 19:55 UTC
    Update - The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  4. 04 Sep · 20:05 UTC 🟡 Monitoring atom

    Sep 4, 20:05 UTC
    Monitoring - The fix has been rolled out and we are seeing signs of recovery.

    Sep 4, 19:55 UTC
    Update - The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  5. 04 Sep · 19:55 UTC 🟡 Identified atom

    Sep 4, 19:55 UTC
    Update - The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  6. 04 Sep · 19:33 UTC 🟡 Identified atom

    Sep 4, 19:33 UTC
    Update - We are continuing to work on a fix for this issue.

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  7. 04 Sep · 19:33 UTC 🟡 Identified atom

    Sep 4, 19:33 UTC
    Identified - The issue has been identified and a fix is being implemented.

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  8. 04 Sep · 19:21 UTC 🟡 Investigating atom

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.

  9. 04 Sep · 19:11 UTC 🟡 Investigating atom

    Sep 4, 19:11 UTC
    Investigating - We've identified an issue where some customers may experience increased latency for Sandbox API requests. We are currently investigating this issue. We will provide additional updates as they become available.

Source

Official Vercel status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.