Global IT infrastructure status

GITHUB

🟢 Operational

Disruption with Copilot Code Review

Resolved

Started
2026-09-04 20:39 UTC
17 days ago
Last update
2026-09-09 17:07 UTC
12 days ago
Duration
1h 47m

Timeline

  1. 09 Sep · 17:07 UTC 🟠 Resolved atom

    Sep 4, 22:26 UTC
    Resolved - On September 4, 2026, between 20:04 and 22:26 UTC, GitHub Copilot code review experienced an increased failure rate. Affected pull request reviews failed to complete or post review comments.

    The incident was caused by a change to the service’s authentication permissions that prevented it from submitting affected reviews to the GitHub API. We reverted the change and restored normal operation by 22:26 UTC.

    We apologize for the disruption.

    Sep 4, 22:25 UTC
    Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.

    Sep 4, 21:54 UTC
    Update - We are applying the mitigation and expect recovery within approximately 30 minutes.

    Sep 4, 20:57 UTC
    Update - Some users may be experiencing failures when using Copilot code review. We have identified the root cause and are working on a mitigation.

    Sep 4, 20:39 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  2. 04 Sep · 22:26 UTC 🟠 Resolved atom

    Sep 4, 22:26 UTC
    Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

    Sep 4, 22:25 UTC
    Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.

    Sep 4, 21:54 UTC
    Update - We are applying the mitigation and expect recovery within approximately 30 minutes.

    Sep 4, 20:57 UTC
    Update - Some users may be experiencing failures when using Copilot code review. We have identified the root cause and are working on a mitigation.

    Sep 4, 20:39 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  3. 04 Sep · 21:54 UTC 🟠 Identified atom

    Sep 4, 21:54 UTC
    Update - We are applying the mitigation and expect recovery within approximately 30 minutes.

    Sep 4, 20:57 UTC
    Update - Some users may be experiencing failures when using Copilot code review. We have identified the root cause and are working on a mitigation.

    Sep 4, 20:39 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  4. 04 Sep · 20:57 UTC 🟠 Identified atom

    Sep 4, 20:57 UTC
    Update - Some users may be experiencing failures when using Copilot code review. We have identified the root cause and are working on a mitigation.

    Sep 4, 20:39 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  5. 04 Sep · 20:39 UTC 🟠 Investigating atom

    Sep 4, 20:39 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

Source

Official GitHub status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.