Global IT infrastructure status

GITHUB

🟢 Operational

Degradation in repos contents API

Resolved

Started
2026-09-04 22:02 UTC
17 days ago
Last update
2026-09-15 23:34 UTC
6 days ago
Duration
21m

Timeline

  1. 15 Sep · 23:34 UTC 🟡 Resolved atom

    Sep 4, 22:23 UTC
    Resolved - On September 4, 2026, between approximately 21:45 and 22:07 UTC, some users experienced errors and elevated latency for repository operations. The incident was fully resolved at 22:23 UTC.

    The cause was a capacity change that spread one of our clusters across additional availability zones; our zone-aware traffic routing kept sending requests to the original zone for performance, overloading a small set of servers while the new capacity sat idle. We resolved the incident by reverting the change and letting traffic rebalance.

    We are improving per-zone capacity guarantees, cross-zone load-shedding, and pre-production testing of multi-zone changes to prevent recurrence.

    Sep 4, 22:02 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  2. 04 Sep · 22:23 UTC 🟡 Resolved atom

    Sep 4, 22:23 UTC
    Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

    Sep 4, 22:02 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  3. 04 Sep · 22:02 UTC 🟡 Investigating atom

    Sep 4, 22:02 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

Source

Official GitHub status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.