Global IT infrastructure status

KRAKEN

🟢 Operational

Dual-Currency Investments

Resolved

Started
2026-09-10 14:00 UTC
11 days ago
Last update
2026-09-10 14:34 UTC
11 days ago
Duration
34m

Timeline

  1. 10 Sep · 14:34 UTC 🔵 Resolved atom

    Sep 10, 14:34 UTC
    Completed - The scheduled maintenance has been completed.

    Sep 10, 14:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 9, 15:51 UTC
    Scheduled - On September 10th at 14:00 UTC, dual-currency investments will undergo maintenance for up to 10 minutes. During this time, clients may be unable to create new investments or view rates. Existing investments will not be affected.

  2. 10 Sep · 14:00 UTC 🔵 Investigating atom

    Sep 10, 14:00 UTC
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 9, 15:51 UTC
    Scheduled - On September 10th at 14:00 UTC, dual-currency investments will undergo maintenance for up to 10 minutes. During this time, clients may be unable to create new investments or view rates. Existing investments will not be affected.

  3. 09 Sep · 15:51 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 10, 14:00 - 14:30 UTC

    Sep 9, 15:51 UTC
    Scheduled - On September 10th at 14:00 UTC, dual-currency investments will undergo maintenance for up to 10 minutes. During this time, clients may be unable to create new investments or view rates. Existing investments will not be affected.

Source

Official Kraken status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.