Global IT infrastructure status

GITLAB

⚪ Unknown

Delay in CI job processing

Investigating

Started
2026-09-09 16:32 UTC
12 days ago
Last update
2026-09-09 18:12 UTC
12 days ago
Running for
12d 7h

Timeline

  1. 09 Sep · 18:12 UTC ⚪ Investigating rss

    September 9, 2026 16:32 UTC
    Investigating - We're observing an increase in CI job queues. Users may see jobs stuck in a pending state for longer than usual. Jobs may not fire their associated webhooks or integrations. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

    September 9, 2026 16:58 UTC
    Investigating - We're still observing elevated CI job queues and are working to address the problem. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

    September 9, 2026 17:35 UTC
    Monitoring - CI job execution delays have improved significantly, and the backlog of pending jobs is shrinking. We're continuing to monitor the situation.

    September 9, 2026 18:12 UTC
    Resolved - We are no longer observing delays in CI job execution and the backlog of pending jobs has been worked through. We'll now be marking this as resolved.

  2. 09 Sep · 17:35 UTC ⚪ Investigating rss

    September 9, 2026 16:32 UTC
    Investigating - We're observing an increase in CI job queues. Users may see jobs stuck in a pending state for longer than usual. Jobs may not fire their associated webhooks or integrations. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

    September 9, 2026 16:58 UTC
    Investigating - We're still observing elevated CI job queues and are working to address the problem. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

    September 9, 2026 17:35 UTC
    Monitoring - CI job execution delays have improved significantly, and the backlog of pending jobs is shrinking. We're continuing to monitor the situation.

  3. 09 Sep · 16:58 UTC ⚪ Investigating rss

    September 9, 2026 16:32 UTC
    Investigating - We're observing an increase in CI job queues. Users may see jobs stuck in a pending state for longer than usual. Jobs may not fire their associated webhooks or integrations. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

    September 9, 2026 16:58 UTC
    Investigating - We're still observing elevated CI job queues and are working to address the problem. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

  4. 09 Sep · 16:32 UTC ⚪ Investigating rss

    September 9, 2026 16:32 UTC
    Investigating - We're observing an increase in CI job queues. Users may see jobs stuck in a pending state for longer than usual. Jobs may not fire their associated webhooks or integrations. Details in: https://gitlab.com/gitlab-com/gl-infra/production/-/work_items/22897

Source

Official GitLab status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.