Global IT infrastructure status

GEMINI EXCHANGE

🟢 Operational

Gemini Exchange Connectivity Issues

Resolved

Started
2026-09-10 06:00 UTC
11 days ago
Last update
2026-09-10 08:53 UTC
11 days ago
Duration
2h 52m

Timeline

  1. 10 Sep · 08:53 UTC 🟠 Resolved atom

    Sep 10, 04:53 EDT
    Resolved - This incident has been resolved.

    Sep 10, 04:53 EDT
    Update - We are continuing to investigate this issue.

    Sep 10, 02:00 EDT
    Investigating - Customers in some APAC countries may experience slow connectivity and timeouts when accessing Gemini Exchange via web or the mobile app. The team is investigating. All customer accounts and funds remain completely secure.

  2. 10 Sep · 06:00 UTC 🟠 Investigating atom

    Sep 10, 02:00 EDT
    Investigating - Customers in some APAC countries may experience slow connectivity and timeouts when accessing Gemini Exchange via web or the mobile app. The team is investigating. All customer accounts and funds remain completely secure.

Source

Official Gemini Exchange status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.