🟡 Degraded
Resolved: Impact to Venmo Payments (PP-LIVE-108344)
Resolved
- Started
- 2026-09-10 16:25 UTC
11 days ago - Last update
- 2026-09-10 16:25 UTC
11 days ago - Duration
- 0s
Timeline
-
10 Sep · 16:25 UTC
🟡 Resolved
atom
Resolved: The issue affecting Venmo transactions has been resolved, and services have returned to normal. Our team continues to monitor the environment to ensure stability. We apologize for any inconvenience.
Initial Notification: Venmo is currently experiencing service degradation affecting some transactions and account-related functionality. Our technical teams are actively investigating and working to restore normal service.
Affected Regions: Global
Source
Official PayPal status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.