Global IT infrastructure status

GEMINI EXCHANGE

🟢 Operational

Delayed Polkadot Deposits and Withdrawals

Resolved

Started
2026-09-10 18:29 UTC
11 days ago
Last update
2026-09-10 21:44 UTC
11 days ago
Duration
3h 15m

Timeline

  1. 10 Sep · 21:44 UTC 🟡 Resolved atom

    Sep 10, 17:44 EDT
    Resolved - This incident has been resolved.

    Sep 10, 14:29 EDT
    Investigating - Customers may experience a delay in processing Polkadot deposits and withdrawals. All customer accounts and funds remain completely secure. Updates will be provided once they are available.

  2. 10 Sep · 18:29 UTC ⚪ Investigating atom

    Sep 10, 14:29 EDT
    Investigating - Customers may experience a delay in processing Polkadot deposits and withdrawals. All customer accounts and funds remain completely secure. Updates will be provided once they are available.

Source

Official Gemini Exchange status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.