🟢 Operational
eOTC will be down for maintenance on Friday Sep 11th 9:00am - 12:00pm EDT
Resolved
- Started
- 2026-09-11 13:00 UTC
10 days ago - Last update
- 2026-09-11 16:00 UTC
10 days ago - Duration
- 3h
Timeline
-
11 Sep · 16:00 UTC
🔵 Resolved
atom
Sep 11, 12:00 EDT
Completed - The scheduled maintenance has been completed.
Sep 11, 09:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Sep 10, 17:25 EDT
Scheduled - We will be undergoing scheduled maintenance during this time. -
11 Sep · 13:00 UTC
🔵 Investigating
atom
Sep 11, 09:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Sep 10, 17:25 EDT
Scheduled - We will be undergoing scheduled maintenance during this time. -
11 Sep · 12:00 UTC
🔵 Investigating
atom
THIS IS A SCHEDULED EVENT Sep 11, 09:00 - 12:00 EDT
Sep 10, 17:25 EDT
Scheduled - We will be undergoing scheduled maintenance during this time. -
10 Sep · 21:25 UTC
🔵 Investigating
atom
THIS IS A SCHEDULED EVENT Sep 11, 09:00 - 12:00 EDT
Sep 10, 17:25 EDT
Scheduled - We will be undergoing scheduled maintenance during this time.
Source
Official Gemini Exchange status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.