Global IT infrastructure status

GITHUB

🟢 Operational

Actions Larger Runner Jobs for some customers may be slow to start

Resolved

Started
2026-09-14 18:40 UTC
7 days ago
Last update
2026-09-18 23:11 UTC
3 days ago
Duration
55m

Timeline

  1. 18 Sep · 23:11 UTC 🟡 Resolved atom

    Sep 14, 19:35 UTC
    Resolved - On September 14, 2026, between 16:10 and 19:01 UTC, some customers using GitHub Actions larger runners experienced longer-than-normal wait times for jobs to start. During this period, 5.7% of larger-runner jobs were affected.

    A routine expansion of our compute capacity exposed a bug in how our provisioning system handled capacity records when selecting where to create runner virtual machines. This slowed the creation of new runners, leaving insufficient runner capacity to start affected jobs promptly.

    We restored normal provisioning by correcting the affected capacity records. We have fixed the underlying capacity-selection bug to prevent this failure from recurring. We have also added alerts for VM-record creation failures associated with this capacity issue.

    Sep 14, 19:01 UTC
    Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.

    Sep 14, 18:40 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  2. 14 Sep · 19:35 UTC 🟡 Resolved atom

    Sep 14, 19:35 UTC
    Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

    Sep 14, 19:01 UTC
    Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.

    Sep 14, 18:40 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  3. 14 Sep · 19:01 UTC 🟡 Monitoring atom

    Sep 14, 19:01 UTC
    Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.

    Sep 14, 18:40 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

  4. 14 Sep · 18:40 UTC 🟡 Investigating atom

    Sep 14, 18:40 UTC
    Investigating - We are investigating reports of impacted performance for some GitHub services.

Source

Official GitHub status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.