Global IT infrastructure status

GEMINI EXCHANGE

🟢 Operational

Scheduled maintenance - Trading services upgrade

Resolved

Started
2026-09-15 06:45 UTC
6 days ago
Last update
2026-09-15 07:15 UTC
6 days ago
Duration
30m

Timeline

  1. 15 Sep · 07:15 UTC 🔵 Resolved atom

    Sep 15, 03:15 EDT
    Completed - The scheduled maintenance has been completed.

    Sep 15, 02:45 EDT
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 15, 02:34 EDT
    Scheduled - During this time, some customers may experience a brief sub-second order rejection.

  2. 15 Sep · 06:45 UTC 🔵 Investigating atom

    Sep 15, 02:45 EDT
    In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.

    Sep 15, 02:34 EDT
    Scheduled - During this time, some customers may experience a brief sub-second order rejection.

  3. 15 Sep · 06:34 UTC 🔵 Investigating atom

    THIS IS A SCHEDULED EVENT Sep 15, 02:45 - 03:15 EDT

    Sep 15, 02:34 EDT
    Scheduled - During this time, some customers may experience a brief sub-second order rejection.

Source

Official Gemini Exchange status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.