Global IT infrastructure status

CLOUDFLARE

🟢 Operational

Network latency affecting Singapore

Resolved

Started
2026-09-15 07:15 UTC
6 days ago
Last update
2026-09-15 07:35 UTC
6 days ago
Duration
19m

Timeline

  1. 15 Sep · 07:35 UTC 🟡 Resolved atom

    Sep 15, 07:35 UTC
    Resolved - This incident has been resolved.

    Sep 15, 07:16 UTC
    Monitoring - A fix has been implemented and we are monitoring the results.

    Sep 15, 07:15 UTC
    Investigating - Cloudflare is investigating issues with network performance in Singapore. We are working to analyse and mitigate this problem. More updates to follow shortly.

  2. 15 Sep · 07:16 UTC 🟡 Monitoring atom

    Sep 15, 07:16 UTC
    Monitoring - A fix has been implemented and we are monitoring the results.

    Sep 15, 07:15 UTC
    Investigating - Cloudflare is investigating issues with network performance in Singapore. We are working to analyse and mitigate this problem. More updates to follow shortly.

  3. 15 Sep · 07:15 UTC 🟡 Investigating atom

    Sep 15, 07:15 UTC
    Investigating - Cloudflare is investigating issues with network performance in Singapore. We are working to analyse and mitigate this problem. More updates to follow shortly.

Source

Official Cloudflare status — view original incident ↗

IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.