🟢 Operational
Disruption with some GitHub services
Resolved
- Started
- 2026-09-15 09:48 UTC
6 days ago - Last update
- 2026-09-18 17:08 UTC
3 days ago - Duration
- 10h 12m
Timeline
-
18 Sep · 17:08 UTC
🟠 Resolved
atom
Sep 15, 20:00 UTC
Resolved - On September 15, 2026 between 15:30 and 20:00 UTC, some Copilot code reviews on pull requests failed to complete. The cause was increased latency in an internal caching service that GitHub Copilot Code Review relies on to coordinate its review jobs. This caused a timeout in lock acquisition, which interrupted the job. We reverted the change to the internal caching service and restored normal operation by 20:00 UTC.
We sincerely apologize for the disruption.
Sep 15, 19:48 UTC
Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.
Sep 15, 19:11 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 20:00 UTC
🟠 Resolved
atom
Sep 15, 20:00 UTC
Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 15, 19:48 UTC
Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.
Sep 15, 19:11 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 19:48 UTC
🟠 Monitoring
atom
Sep 15, 19:48 UTC
Monitoring - The degradation has been mitigated. We are monitoring to ensure stability.
Sep 15, 19:11 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 19:11 UTC
🟠 Investigating
atom
Sep 15, 19:11 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 11:17 UTC
🟠 Resolved
atom
Sep 15, 11:17 UTC
Resolved - This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 15, 11:17 UTC
Update - The issues with our upstream model provider have been resolved, and Claude Fable 5.1 is once again available in Copilot products and IDE surfaces.
We will continue monitoring to ensure stability, but mitigation is complete.
Sep 15, 11:09 UTC
Update - We continue to monitor intermittent errors affecting Claude Fable 5.1 in some Copilot products and integrated development environments. Customer-facing metrics have recovered, and we are awaiting confirmation from our upstream provider that the issue will not recur. Customers can select another model or Auto in the meantime.
Sep 15, 10:32 UTC
Update - We continue to investigate intermittent errors affecting Claude Fable 5.1 in some Copilot products and integrated development environments. Customers can use another model or select Auto while we monitor the situation.
Sep 15, 10:20 UTC
Investigating - Copilot AI Model Providers is experiencing degraded performance. We are continuing to investigate.
Sep 15, 09:48 UTC
Monitoring - We are investigating degraded availability for Claude Fable 5.1, affecting some Copilot products and integrated development environments. The issue is caused by a problem with our upstream model provider. Customers can use another model or select Auto while we investigate.
Sep 15, 09:47 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 11:09 UTC
🟠 Identified
atom
Sep 15, 11:09 UTC
Update - We continue to monitor intermittent errors affecting Claude Fable 5.1 in some Copilot products and integrated development environments. Customer-facing metrics have recovered, and we are awaiting confirmation from our upstream provider that the issue will not recur. Customers can select another model or Auto in the meantime.
Sep 15, 10:32 UTC
Update - We continue to investigate intermittent errors affecting Claude Fable 5.1 in some Copilot products and integrated development environments. Customers can use another model or select Auto while we monitor the situation.
Sep 15, 10:20 UTC
Investigating - Copilot AI Model Providers is experiencing degraded performance. We are continuing to investigate.
Sep 15, 09:48 UTC
Monitoring - We are investigating degraded availability for Claude Fable 5.1, affecting some Copilot products and integrated development environments. The issue is caused by a problem with our upstream model provider. Customers can use another model or select Auto while we investigate.
Sep 15, 09:47 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 10:32 UTC
🟠 Identified
atom
Sep 15, 10:32 UTC
Update - We continue to investigate intermittent errors affecting Claude Fable 5.1 in some Copilot products and integrated development environments. Customers can use another model or select Auto while we monitor the situation.
Sep 15, 10:20 UTC
Investigating - Copilot AI Model Providers is experiencing degraded performance. We are continuing to investigate.
Sep 15, 09:48 UTC
Monitoring - We are investigating degraded availability for Claude Fable 5.1, affecting some Copilot products and integrated development environments. The issue is caused by a problem with our upstream model provider. Customers can use another model or select Auto while we investigate.
Sep 15, 09:47 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 10:20 UTC
🟠 Investigating
atom
Sep 15, 10:20 UTC
Investigating - Copilot AI Model Providers is experiencing degraded performance. We are continuing to investigate.
Sep 15, 09:48 UTC
Monitoring - We are investigating degraded availability for Claude Fable 5.1, affecting some Copilot products and integrated development environments. The issue is caused by a problem with our upstream model provider. Customers can use another model or select Auto while we investigate.
Sep 15, 09:47 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services. -
15 Sep · 09:48 UTC
🟠 Monitoring
atom
Sep 15, 09:48 UTC
Monitoring - We are investigating degraded availability for Claude Fable 5.1, affecting some Copilot products and integrated development environments. The issue is caused by a problem with our upstream model provider. Customers can use another model or select Auto while we investigate.
Sep 15, 09:47 UTC
Investigating - We are investigating reports of impacted performance for some GitHub services.
Source
Official GitHub status — view original incident ↗
IT Status normalizes vendor wording into a common vocabulary and rewrites machine-shaped titles for readability. The vendor's page remains authoritative.